RouterOS技术分享

统计PPPOE在线人数,单行代码

:global ppp :set ppp ([:len [/ppp active find]]) :log warning $ppp RouterOS-WINBOX标题栏显示ppp当前在线,最终实现的功能如下图: 将下面的脚本加计划周期性更新即可: :global zxzj [:len [/ppp active find]] sy id set n=("\B5\B1\C7\B0\D4\DA\CF\DF"."$zxzj"." \C8\……
17/10/13 | 暂无评论 | 17阅读 阅读详情

定期从公网http下载更新文件到ROS files

此脚本可用于实现以下需求: 多台ROS需要频繁更新,比如推广信息,公告内容等 在ROS中加入计划定期执行脚本,检测更新,后续将新文件上传到服务端即可。 脚本内容: /tool fetch url=http://www.youname.com/src.html dst-path=dst/dst.html “http://www.youname.com/src.html”……
17/10/13 | 暂无评论 | 10阅读 阅读详情

bonding七种模式的特点和应用

第一种: round robin(rr) 模式特点:所有链路处于负载均衡状态,轮询方式往每条链路发送报文,基于per packet方式发送。服务上ping 一个相同地址:1.1.1.1 双网卡的两个网卡都有流量发出。负载到两条链路上,说明是基于per packet方式 ,进行轮询发送。(2)这模式的特点增加……
17/10/13 | 暂无评论 | 11阅读 阅读详情

ROS capsman 开启命令 telnet不能自动登陆

如ROS能自动telnet输入帐号密码,那么连接后执行 /interface wireless cap set enabled=yes interfaces=wlan1 discovery-interfaces=ether1,ether2,ether3,ether4 一条命令即可开启下面路由器的cap 以下脚本未完工,卡在telnet输入帐号密码上 { :local humac; /ip neighbor :f……
17/10/13 | 暂无评论 | 6阅读 阅读详情

ROS检测线路状态脚本并自动重新拨号

:local a :local remoteip 113.81.200.1 :local linkname /interface pppoe-client :foreach i in=[find running] do={ :set linkname [get $i name] :set a [/ping $remoteip interface=$linkname count=2 interval=0.2] :if ($a = 0) do={ disable $linkname /ip address remo……
17/10/13 | 暂无评论 | 6阅读 阅读详情

ROS用简单限速做小包优先

内网管理中,一般的简单限速,当客户机把带宽用完时,会造成整个客户机玩游戏、PING等也会丢包,我们知道PING、游戏一般数据包都是用小包,在此我们用简单限速做小包优先。 1.首先,标记低于512为小包,名字为YX,,我们用forward,不区分上传下载: /ip firewall mangle add ch……
17/10/13 | 暂无评论 | 6阅读 阅读详情

固定IP限速脚本6.XX-带突发限速

172.93.112.2-172.93.112.255 172.93.113.1-172.93.113.255 172.93.114.1-172.93.114.255 172.93.115.1-172.93.115.255 172.93.116.1-172.93.116.255 172.93.117.1-172.93.117.255 172.93.118.1-172.93.118.255 172.93.119.1-172.93.119.254 :for roszj from 2 to 255 do={/queu……
17/10/13 | 暂无评论 | 6阅读 阅读详情

检测ip-dns-cache缓存数量超5000发邮件

:global dd :set dd [/ip dns cache print count-only] :log warning ("DNS-Cach-数量:".$dd) if ($dd > 5000) do={ /tool e-mail send to="1106856308@qq.com" subject=($dd."-CS-DNS-Cache-超载") }
17/10/12 | 1 条评论 | 5阅读 阅读详情