RouterOS技术分享

ROS检测线路状态脚本并自动重新拨号

发布于2017年10月13日 | 暂无评论 | 3阅读 | 未分类

:local a
:local remoteip 113.81.200.1
:local linkname

/interface pppoe-client
:foreach i in=[find running] do={
:set linkname [get $i name]
:set a [/ping $remoteip interface=$linkname count=2 interval=0.2]

:if ($a = 0) do={
disable $linkname
/ip address
remove [find interface=$linkname]
/interface pppoe-client
enable $linkname
:log error ($linkname."已重新拨号")
/tool e-mail send to="1106856308@qq.com" subject=($linkname."-HOT重新拨号")
}}
:log error "一切正常";

暂无评论

发布评论